Trimble Jobpac Connect Login Issue

Incident Report for Trimble Viewpoint

Resolved

Dear Valued Customers,

Following a period of sustained stability and successful monitoring, we are officially marking the Trimble ID (TID) login issue for Jobpac as Resolved.

Our internal telemetry and user feedback confirm that the authentication gateway is performing at standard levels. We have concluded our active monitoring phase and all services are operating as expected.

We thank you for your patience while we worked with our global teams and partners to restore service.

Regards,
The Jobpac Connect Team
Posted Apr 15, 2026 - 00:24 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 14, 2026 - 11:22 UTC

Monitoring

Dear Valued Jobpac Connect Users,

We are pleased to confirm that the authentication issues involving Trimble ID (TID) have been resolved. In coordination with our global identity teams, a fix was implemented to address the redirect loops affecting Jobpac Connect logins.

Current Status: All systems are operational. Our engineering team has moved into an active monitoring phase to ensure sustained stability and optimal performance across all regions.

Regards,
The Jobpac Connect Team
Posted Apr 14, 2026 - 11:21 UTC

Update

Dear Jobpac Connect Users,

By way of an update, Our technical teams are continuing to investigate the authentication difficulties reported earlier this afternoon. We have now engaged the global Trimble ID (TID) engineering teams to assist in isolating the root cause within the identity gateway.

We thank you for your patience while we investigate this issue.

Regards
Jobpac Connect Team
Posted Apr 14, 2026 - 07:42 UTC

Investigating

Dear Jobpac Connect Users,

We are currently aware of an issue affecting users attempting to log in to Jobpac Connect using Trimble ID (TID). Users may encounter error messages or timeouts during the authentication process.

Our technical teams are investigating the root cause with the global identity services team. We apologize for the inconvenience and will provide an update as soon as more information is available.

We thank you for your patience while we investigate this issue.

Regards
Jobpac Connect Team
Posted Apr 14, 2026 - 06:43 UTC
This incident affected: Australia / New Zealand (Jobpac Connect).