We are pleased to confirm that the remediation of all impacted customer data has been successfully completed.
We appreciate your patience during this process and apologize for any inconvenience it may have caused.
Best regards,
The Trimble Jobpac Connect Team
Posted Sep 29, 2025 - 21:41 UTC
Update
Dear Jobpac Connect Customers,
Following our last communication, we would like to provide you with a progress update on the data rectification process.
Our team has completed the analysis of the impacted data and is actively working with customers who have raised cases, as well as proactively reaching out to those we have identified.
We have made excellent progress and anticipate that this work will be completed within the next few days.
We apologize for the inconvenience and thank you for your patience.
Best regards,
The Trimble Jobpac Connect Team
Posted Sep 24, 2025 - 01:20 UTC
Monitoring
Dear Jobpac Connect Customers,
We are writing to provide a quick update on the timesheet posting issue.
Our team continues to work on fixing the affected data, both for customers who have logged cases and those we have proactively identified. We anticipate this rectification work will be completed in the next few days.
We apologize for the inconvenience and thank you for your patience.
Best regards,
The Trimble Jobpac Connect Team
Posted Sep 19, 2025 - 00:39 UTC
Identified
Dear Jobpac Connect Customers,
We are writing to inform you of a recently resolved issue that may have impacted some customers that ran payroll processing between 5:00 PM on 12/9/2025 and 2:20 PM on 17/9/2025 which may have resulted in timesheet postings not completing properly.
What was affected: The issue was prominent when the Timesheet Posting process was combined with the Payroll process. Crucial Note: This issue DID NOT affect the payment of employees. It was isolated to timesheet costing and general ledger clearing. Resolution: The problem has been resolved, and the payroll system is now operating normally.
We are proactively scanning to identify any customers that may have been impacted. If you notice any inconsistencies in your Timesheet clearing accounts, please log a case with us, and we will rectify it promptly.
We apologize for any inconvenience this may have caused.
Best regards, The Trimble Jobpac Connect Team
Posted Sep 18, 2025 - 00:09 UTC
This incident affected: Australia / New Zealand (Jobpac Connect).