We continue to work with Microsoft to actively resolve the issue. In the interim, we have rolled back the recent AVD update, which was identified as the source of performance issues affecting some customers. If you continue to experience performance issues while using AVD to access your application, please submit a support ticket for further assistance.
Posted Apr 30, 2025 - 17:23 UTC
Identified
We are currently investigating a performance issue affecting some VEC and PCC customers. Our team is actively collaborating with Microsoft to resolve the problem. We will provide further updates as they become available.
Posted Apr 28, 2025 - 16:35 UTC
This incident affects: North America (ProContractor, Viewpoint for Cloud).