Trimble Help inaccessible

Incident Report for Trimble Viewpoint

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 13:06 UTC

Identified

Help.trimble.com is currently inaccessible. As a workaround, you can go to trimblehelp.trimble.com.
We've identified the issue and are actively working to correct it. Sorry for the inconvenience.
Posted Apr 12, 2026 - 23:03 UTC
This incident affected: North America (Trimble Help).